21 Aug 2017 
Тех. и админ поддержка » База знаний » Вопросы по настройке скриптов » Как мне сменить версию PHP
 Как мне сменить версию PHP
Решение На наших серверах предустановлены и используются сразу несколько версий компилятора PHP:
1. PHP 5.3
2. PHP 5.4
3. PHP 5.5
4. PHP 5.6
5. PHP 7.0
6. PHP 7.1

По умолчанию на всех серверах используется версия PHP 5.4, для его использования никаких изменений вносить не требуется.

Для того, чтобы использовать другую версию компилятора PHP в своей работе, необходимо внести изменения или создать новый файл .htaccess в корневой директории домена, для которого нужно подключить определенную версию (для виртуальных хостинг-планов это директория public_html для основного домена и public_html/имя_домена - для дополнительных доменов по умолчанию).

Для использования скриптами компилятора PHP 5.3 необходимо внести в Ваш файл .htaccess следующую строку:
AddHandler application/x-httpd-php53 .php
Для использования скриптами компилятора PHP 5.5 необходимо внести в Ваш файл .htaccess следующую строку:
AddHandler application/x-httpd-php55 .php
Для использования скриптами компилятора PHP 5.6 необходимо внести в Ваш файл .htaccess следующую строку:
AddHandler application/x-httpd-php56 .php
Для использования скриптами компилятора PHP 7.0 необходимо внести в Ваш файл .htaccess следующую строку:
AddHandler application/x-httpd-php70 .php
Для использования скриптами компилятора PHP 7.1 необходимо внести в Ваш файл .htaccess следующую строку:
AddHandler application/x-httpd-php71 .php

При необходимости можно изменить некоторые параметры отличной от PHP 5.4 версии, создав в корне аккаунта файл php.ini и прописав в него необходимые значения. Некоторые параметры, в частности, время выполнения скрипта, отключение open_basedir и некоторые другие, таким образом изменить невозможно.

Использовать в работе можно только одну из версий PHP, поэтому в файл .htaccess вписывается только одна нужная строка для необходимой версии PHP.

Также обратите внимание на то, что некоторые скрипты после установки создают свой .htaccess файл, заменяя при этом существующий. Поэтому, после установки также необходимо проверить наличие директивы смены версии РНР.



Подробности статьи
Cтатья №:150
Создано:25 Jul 2013 10:26 PM

 Этот ответ мне помог  Этот ответ мне не помог

 Назад
 Войти [Пароль утерян] 
Электронная почта:
Пароль:
Запомнить меня:
 
 Поиск
 Опции статьи
Главная | Регистрация | Отправить тикет | База знаний | Новости | Загрузки
Язык:

Support Service Ruskyhost.ru © 2004-2013